Commit b7a5fed7 authored by Ralf Jung's avatar Ralf Jung
Browse files

Merge branch 'ralf/drop-8.11' into 'master'

drop support for Coq 8.11

See merge request !377
parents 7c4fd7d6 d9f1c297
Pipeline #65772 passed with stage
in 13 minutes and 50 seconds
......@@ -78,16 +78,9 @@ build-coq.8.13.2:
DENY_WARNINGS: "1"
build-coq.8.12.2:
<<: *template
variables:
OPAM_PINS: "coq version 8.12.2"
DENY_WARNINGS: "1"
OCAML: "ocaml-base-compiler.4.07.1"
build-coq.8.11.2:
<<: *template
<<: *branches_and_mr
variables:
OPAM_PINS: "coq version 8.11.2"
OPAM_PINS: "coq version 8.12.2"
DENY_WARNINGS: "1"
OCAML: "ocaml-base-compiler.4.07.1"
......@@ -3,6 +3,8 @@ API-breaking change is listed.
## std++ master
Coq 8.11 is no longer supported.
- Make sure that `gset` and `mapset` do not bump the universe.
- Rewrite `tele_arg` to make it not bump universes. (by Gregory Malecha, BedRock Systems)
......
......@@ -45,7 +45,7 @@ Notably:
This version is known to compile with:
- Coq version 8.11.2 / 8.12.2 / 8.13.2 / 8.14.1 / 8.15.0
- Coq version 8.12.2 / 8.13.2 / 8.14.1 / 8.15.0
## Installing via opam
......
......@@ -33,7 +33,7 @@ tags: [
]
depends: [
"coq" { (>= "8.11" & < "8.16~") | (= "dev") }
"coq" { (>= "8.12" & < "8.16~") | (= "dev") }
]
build: [make "-j%{jobs}%"]
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment