Commit dda0bf71 authored by Ralf Jung's avatar Ralf Jung
Browse files

drop support for Coq 8.10

parent 72fe576e
......@@ -32,6 +32,11 @@ build-coq.dev:
variables:
OPAM_PINS: "coq version dev"
build-coq.8.13.dev:
<<: *template
variables:
OPAM_PINS: "coq version 8.13.dev"
build-coq.8.12.1:
<<: *template
variables:
......@@ -48,11 +53,6 @@ build-coq.8.11.2:
variables:
OPAM_PINS: "coq version 8.11.2"
build-coq.8.10.2:
<<: *template
variables:
OPAM_PINS: "coq version 8.10.2"
# Nightly job with a known-to-work Coq version
# (so failures must be caused by std++)
build-stdpp.dev-coq.8.12.1:
......@@ -65,7 +65,7 @@ build-stdpp.dev-coq.8.12.1:
- schedules
- api
# Nightly job with latest Coq branch
# Nightly job with latest Coq beta branch
build-stdpp.dev-coq.8.13.dev:
<<: *template
variables:
......
......@@ -5,7 +5,7 @@ lemma.
## Iris master
With this release, we dropped support for Coq 8.9.
With this release, we dropped support for Coq 8.9 and Coq 8.10.
We also split Iris into multiple opam packages: `coq-iris` no longer contains
HeapLang, which is now in a separate package `coq-iris-heap-lang`.
......
......@@ -30,7 +30,7 @@ Importing Iris has some side effects as the library sets some global options.
This version is known to compile with:
- Coq 8.10.2 / 8.11.2 / 8.12.1
- Coq 8.11.2 / 8.12.1
- A development version of [std++](https://gitlab.mpi-sws.org/iris/stdpp)
If you need to work with Coq 8.7 or Coq 8.8, please check out the
......
......@@ -13,7 +13,7 @@ iris.prelude, iris.algebra, iris.si_logic, iris.bi, iris.proofmode, iris.base_lo
"""
depends: [
"coq" { (>= "8.10.2" & < "8.14~") | (= "dev") }
"coq" { (>= "8.11" & < "8.14~") | (= "dev") }
"coq-stdpp" { (= "dev.2020-11-11.2.6385b547") | (= "dev") }
]
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment